Notices
 
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. Collapse Details
    Re: cccam plugin for linux. 
    #11
    Board Senior Member bonilla's Avatar
    Join Date
    Aug 2012
    Location
    In this world
    Posts
    212
    Thanks Thanks Given 
    11
    Thanks Thanks Received 
    62
    Thanked in
    48 Posts
    Total Downloaded
    0
    Hello,

    Here you find the solution to your problem (props to ron273 )

    If during the install process you see any warning messages, that is usually OK. An error message could be a problem. If so, write it down and don't go to the next step. ****** the error and see if you can find something. That is how I found out what worked and didn't work.
    At all times in the terminal make sure you are root, unless specifically stated otherwise. I always do sudo -s.
    My linux version is Ubuntu 9.04.
    Kaffeine version: 0.8.7
    Cccam version: 2.0.9
    Kaffeine softcam plugin 0.4.0

    OK, let's get started:
    Open up a terminal window and type sudo -s. This will make you root for the complete install in this terminal window. Enter your root password when asked
    Code:
    apt-get install kaffeine
    apt-get build-dep kaffeine
    apt-get install g++
    apt get install build-essential
    Ok, if this is done, it is time to unpack the kaffeine-sc plugin to a folder. I always use home/your_username/downloads/DVB for this stuff.
    Make sure you unpack it in a seperate directory. In ubuntu I use Ark to do this, but I am sure there are some terminal junkies that can do it from the terminal. If all goes well, you will have the contents unpacked in /home/your_username/DVB/kaffeine-sc-plugin-0.4.0 or something similar, so let's continue.
    Before we go into the terminal again, we need to modify a file. Use your favourite editor and open up the file /home/your_username/DBV/kaffeine-sc-plugin-0.4.0/src/FFdecsa/Makefile. At the top you will find the line
    Code:
    COMPILER=g++34
    . Change this to
    Code:
    COMPILER=g++
    Save the file and exit.
    A second file that gave me trouble was /home/your_username/DVB/kaffeine-sc-plugin-0.4.0/admin/detect-autoconf.pl. During make I got a permission denied error. So go into this directory and CHMOD this file to 777 (I always use Dolphin for this. Right Click on the file and select Properties).

    We are ready to proceed
    Code:
    sh ./configure –without-arts (it did complain about arTs during the first configure and this solved it for me)
    make
    make install
    apt-get install gcc-4.2
    So that was easy, right? If during these steps, you get any errors it might be necessary to install some necessary packages. In that case (and onley then!) do the following:
    apt-get install xorg-dev
    pat-get install libqt3-mt-dev
    apt get install kdelibs4-dev
    In my case this was not needed, they were already installed during step 3.

    Al right, let's compile this puppy!
    Code:
    gcc-4.2 -O -fbuiltin -fomit-frame-pointer -fPIC -shared -o ca.so ca.c -ldl
    Now we need to create the necessary directories and give them the right permissions.
    Code:
    cd /var
    mkdir etc
    chmod 777 etc
    mkdir keys
    chmod 777 keys
    mkdir bin
    chmod 777 bin
    OK, we have all the packages installed and configured. Now it is time to put the Cccam stuff in the right place. To do this, unpack the Cccam-2.0.9 tarball in a directory on your system. I recommend something like /home/your_username/DVB/cccam-2.0.9. After unpacking, you will see some files in the directory.
    Take the file Cccam.x86 and copy it into /var/bin
    CHMOD the file into 777
    Take the Cccam.cfg and copy it into /var/etc
    Finally, from the plugin folder (/home/your_username/downloads/kaffeine-sc-plugin-0.4.0) take the file ca.so and copy it into /var/bin

    Now we are almost done here. To complete the setup, open up Kaffeine and in the menubar goto DVB=>DVB settings. On the left in that window you will notice a new icon, called DVB-plugins. Click on it and you will see your plugins. Click on the Softcam 0.4.0 button and you will see a screen with some tabs. Click on the tab Others and check Enable CCcam client. Click OK and close the program.

    We are now ready to start cccam and Kaffeine.
    Open up a terminal window (not as root!)
    Code:
    cd /var/bin
    LD_PRELOAD=./ca.so ./CCcam.x86 -d
    Cccam is now started.
    Your terminal output should look something like this:
    CODE:
    08:15:06.106 CCcam: ================================================== ====================
    08:15:06.106 CCcam: starting CCcam 2.0.9 compiled on May 20 [email protected]:53:25
    08:15:06.106 CCcam: ================================================== ====================
    /tmp/.CCcam.nodeid open...
    /dev/urandom open...
    Closing 3
    /tmp/.CCcam.nodeid open...
    08:15:06.107 CCcam: online using nodeId ******************x
    /dev/dvb/adapter0/demux0 open...
    Closing 8
    08:15:06.108 CCcam: dvb api3 detected
    08:15:06.108 CCcam: create 1 cam device(s)
    /dev/dvb/adapter0/ca0 open...
    hijacking ca0 open...
    ca0 fd = 8hijacking ca0 ioctl,(8 : 7808 - 0xbff6690c): /dev/dvb/adapter0/ca1 open...
    08:15:06.111 CCcam: added 871 keys from /var/keys/SoftCam.Key
    08:15:06.111 CCcam: added 0 keys from /var/keys/AutoRoll.Key
    08:15:06.111 CCcam: static cw not found or bad
    08:15:06.111 CCcam: parsed 0 entries from /var/etc/CCcam.prio
    08:15:06.111 CCcam: readProviderfile: cannot open /var/etc/CCcam.providers or not found
    08:15:06.111 CCcam: readChannelList: cannot open /var/etc/CCcam.channelinfo or not found
    08:15:06.112 CCcam: server started on port 12000
    The line CCcam: static cw not found or bad does not affect cccam behaviour. Also cccam not finding some files is not a problem. If it looks anything like this, you are good to go.
    Finally start Kaffeine and enjoy!
    If you like my post, please don't hesitate to click on "Thanks"button. Thank you
     
     

  2. Collapse Details
    Re: cccam plugin for linux. 
    #12
    Newbie
    Join Date
    Feb 2012
    Posts
    6
    Thanks Thanks Given 
    3
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Total Downloaded
    0
    archlinux or ubuntu 12 /13.10 it work with Kaffeine & this plugin ?
     
     

  3. Collapse Details
    Re: cccam plugin for linux. 
    #13
    Member
    Join Date
    Feb 2014
    Posts
    35
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts
    Total Downloaded
    0
    Quote Originally Posted by rapy View Post
    archlinux or ubuntu 12 /13.10 it work with Kaffeine & this plugin ?
    I don't know Archlinux but in Ubuntu 12.10/13.10 for installing Kaffeine 0.8.8 (this is the only version that support plug-in) you must download the old missing library manually , because in the repository are too much update.
     
     

Page 2 of 2 FirstFirst 12
Tags for this Thread

View Tag Cloud

 
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •